Users are seeing "Error 1027: Please Check Back Later"
Incident Report for Talk Staind
Resolved
This incident has been resolved.
Posted Jan 21, 2022 - 00:00 CST
Monitoring
Users started receiving "Error 1027: Please Check Back Later" at 12:30 PM! This is due to a DDOS attack that caused nearly 150,000 requests (147,638 to be exact), and the limit of daily requests is 100,000! This issue is expected to last until midnight UTC (when the limit resets)! We will update you as soon as we can, but the primary websites are not affected! We will be checking to see if the backups are affected and update as necessary!
Posted Jan 20, 2022 - 12:45 CST