Users are receiving 404 errors
Incident Report for Talk Staind
Resolved
The incident has been resolved, we will not undergo details as to why this was occurring but we can say it loads normally now!
Posted Feb 09, 2022 - 14:29 CST
Investigating
We are currently investigating reports that users are receiving 404 errors when attempting to visit https://talk-staind.submarine.workers.dev/! We are currently attempting to identify the cause of the issue, and will update you as soon as updates become available!
Posted Feb 09, 2022 - 14:14 CST